(Polski) Quadcopter – OpenLRS i moduły OrangeRX

Sorry, this entry is only available in Polski.

4.40 avg. rating (88% score) - 5 votes

26 Comments

  1. Myślisz, że do takiego rx’a też naliczą dopłaty(cło, vat)?
    http://www.hobbyking.com/hobbyking/store/__79341__OrangeRx_R920X_9Ch_2_4GHz_DSM2_DSMX_CompFullRangeRx_w_SatDivAnt_F_S_S_BUS.html
    Co w ogóle myślisz o tym odbiorniku? Mam zmodowane Devo 7e z wgranym deviation tx(także mogę nadawać DSM2/DSMX jak i w kilku innych standardach). Będzie to mój pierwszy odbiornik, planowałem spiąć go z Naze przez s.bus. Do tej pory Devo używałem do latania moim DM007. Mam też wyjście PPM więc mógł bym podpiąć ten zestaw o którym mówisz, a wolałbym nie zmienić za chwilę rx’a. Dodatkowo słyszałem, że CPPM powyżej 8 kanałów nie działa zbyt stabilnie dlatego wybrałem s.bus który jest zwyczajnym (zanegowanym ale to nie problem) UART’em. Uh, trochę długie wyszło ale mam nadzieję że nie namieszałem za bardzo :D

  2. Świetny artykuł, jak i cała strona.
    Fajna cena tych modułów jest teraz w HobbyKingu http://www.hobbyking.com/hobbyking/store/uh_viewitem.asp?idproduct=40032
    Zostało kilka sztuk.
    Pozdrawiam

    • Dzięki za info o promocji, jak kliknąłem w link to były jeszcze 2szt po 1.95$ czy coś takiego. Myślę sobie idealna okazja, rozlutuje, i przełożę części na płytki microRX które ostatnio sobie zamówiłem z OSH Park. Bo za komplet samych części trzeba i tak zapłacić coś około 10$. Niestety nie udało mi się kupić, bo od tygodnia mój internet ciągnie się jak flaki z olejem – dzięki Multimedia Polska S.A…

  3. Witam.
    Czy mógłby ktoś troszkę jaśniej opisać modyfikacje TX na RX bo mam kilka problemów.
    1. Nie chce się połaczyć do progogramowania
    2. Nie wiem jakie napięcie dostarczyć
    3. PPM rozumiem że na dowolny kanał mogę dać?
    4. Wyjście RSSI czy mogę je dac na jakis wolny port czy jest tylko mozliwość po ppm?
    5. (chyba najistotiniejszy ) Gdzie mogę Dać 5V z regulatora ? bo gnd chyba nie ważne…
    Chciałem się wzorować na opisanym odbiorniku ale brakuje mi w opisie konkretów co gdzie i jak… naj lepiej za rączke :P

  4. Sorry że tak post pod postem ale jakoś tak już mam że jak napiszę o swoich problemach… powoli same się rozwiązują…

    więć żeby nie zostawiać tego tylko dla siebie
    1. Nie chcę się połączyć – jak Autor słusznie stwierdził problem jest z napięciem (ja podałem 5V z regla)
    5. Gdzie dać napięcie z regla… ja dałem na tą białą kość która to łączy moduł z aparaturą (Pinout dla futaby to drugi pin zaraz za PPM opisany jako V+ i przedostatni to GND) Bardziej łopatologicznie to dajemy diody do góry (tak żeby swieciły na nas) w ułożeniu dioda / dioda / przełącznik w tedy białe gniazdo jest po lewej i teraz…
    Pierwszy pusty /Drugi pin od góry licząć to GND /trzeci pusty /i czwarty VCC/i piąty znowu pusty

    • Cześć, zasilanie 5V na zdjęciach jest podpisane jako VCC, a 3.3V jako 3.3V.

      Jeśli chodzi o ustawienie kolejności kanałów, to nie, nie możesz zamieniać takich funkcji jak RSSI czy PPM miejscami, te są ustawione na sztywno. Dowolnie możesz ustawić sobie tylko kanały PWM. Z resztą połącz się do RX i będziesz wszystko wiedział :)

      Zerknij jeszcze na te płytki dla miniaturowego RX:
      Projekt: https://github.com/openLRSng/openLRSminiRX
      3szt za 3,5$: https://oshpark.com/profiles/ABL
      Ja zamówiłem bez złącza SMA, zamierzam przelutować graty z obecnej “wyciętej” płytki na te maleństwo.

  5. Cześć,

    Czy miałeś może już okazję testować zasięg na antenach z zestawu ? Jest sens je wymieniać ?

    Ewentualnie co mogę zrobić z anteną z odbiornika żeby nie wyglądała tak topornie po zamontowaniu w ramę 250?

    ps. Super tutorial !

    Pozdrawiam.
    m00se

  6. Moose anteny ponoć są tak kinowe ze służą tylko dla zabezpieczenia modułu przed upaleniem… Ale możesz je wykorzystać. Zdejmij górna osłonę anteny i juz bedzoe mniejsza i mniej toporne a to już jest punkt wyjściowy na przerobienie tej anteny na 1/4 albo dipola. ja sobie na 5.8 przerabiam tak anteny bo szkoda wywalić a złącza sma może nie są drogie ale na allegro na przesyłkach zbankrutujesz

  7. Admin..
    Ja niestety nie mam możliwości aby przelutowac procka… :-(
    Mam tylko zwykła grotowke… Chyba ze masz ochotę tym się zająć ;-)

  8. Admin

    No i stało się :). Nie podłączyłem anteny do modułu przeprogramowanego jako RX(a tak tego pilnowałem, widać za mało :)). Teraz mam pytanie jaki jest objaw uszkodzenia? Zaznaczę że oba moduły (TX i RX) się widzą.

    Zdrówka życzę

  9. Dokładnie to że działa nie znaczy że działa jak trzeba… często moduł upalony działa ale zasięg jego jest znacznie krótszy od zdrowego.

    • Cześć.

      Mam wątpliwości co do zasięgu. Mam dwa zestawy (TX + RX as TX). Jeden swój w którym jak pisałem zapomniałem raz(no może dwa) o antenie. Max to 50m i zaczynają się problemy. Więc wykonałem test na drugim (tutaj nie mam wątpliwości – anteny zawsze podłączone) i jest dokładnie tak samo. Może jest to kwestia jeszcze samych ustawień samego TX. Macie może sprawdzone ustawienia? Zaznaczę że używam anten tych co fabryka dała..

      Pozdrawiam

  10. Ok. Problemem okazały się anteny. Zrobiłem dwie anteny posiłkując się tutorialami dostępnymi w sieci. Zmierzony zasięg przy 100mW to ok 1km.

    Jakie wy macie osiągi?
    Jakie macie anteny?

    Pozdrawiam
    m00se

    • U siebie jeszcze zasięgu nie sprawdzałem. Po prostu jeszcze nie miałem czasu na spokojnie zabrać gratów w teren i sobie polatać, bo zawsze coś :/ Ale nie liczę na to żeby fabryczne anteny były wykonane dobrze.

  11. Czy u Ciebie zwarcie między port1 a masą buzzera jest celowe?
    Pytam, bo mam pewien problem. Przeróbka TX na RX powiodła się, ale po podłączeniu serw – te drżą mocniej lub słabiej w zależności od ułożenia ich względem modułu. Samymi serwami oczywiście da się sterować.
    Moje zabiegi:
    1. Nie skracałem płytki.
    2. Nie robiłem zwarcia między buzz a port1.
    3. Także nie mam rezystora na końcu linii port 1 R4 – odpłynął podczas lutowania.
    4. Porty z płytki wyprowadziłem kynarem do listwy gold pin. Z kolejnej zrobiłem zasilanie, z kolejnej masę do serw i skleiłem je razem klejem na gorąco.
    5. Dodanie kondensatora między + i – na listwach gold pin nic nie wnosi.
    6. Trzymanie złączy goldpin palcami (w miejscu kleju) uspokaja serwa.

  12. Mały update problemu – zmiana serw z analogowych tg9e na cyfrowe emaxy + analogowe hobbyking4.3 i nie ma drgania….

    • Nie patrz na to połączenie pomiędzy PORT1 a buzzerem. Po prostu musiałem sobie wyprowadzić na coś PORT1 do testów jak rozkminiałem wyprowadzenia. Buzzer został wylutowany a w jego miejsce dałem goldpina, tranzystor który nim steruje ma podniesioną nogę również od strony tej ścieżki – więc to takie tymczasowe rozwiązanie.

      Myślę że taka pajęczyna z kynaru może źle wpływać na sygnał PWM. Prawdopodobnie sygnał będzie przenikał pomiędzy sąsiednimi kanałami i może przez to tańsze serwa głupieją? Te TG9E to jest to “micro” serwo 9 gram tak? Straszne badziewie, z dwóch sztuk jedno mi się okręciło dookoła i samo sobie urwało ogranicznik, drugie przez cały czas buczało i drgało niezależnie od ustawienia.

      Może zabezpiecz to wszystko jakoś bo nie wygląda jakby było odporne na długotrwałe drgania. Ja bym takiej pajęczyny bał się wkładać do modelu.

  13. Jest to takie tymczasowe rozwiązanie do testów. Chyba usunę ten cały kynar i wykorzystam goldy z drugiej strony (oryginalne) do podłączenia serw. Z jednej strony będzie 2g mniej, z drugiej – uzyskałbym więcej usuwając goldy. Losy tego modułu jeszcze są w fazie decyzyjnej…. ;-)

    Sprawdziłem dokładniej i tylko te micro serwa turnigy drgają (wszystkie 17szt które mam, w tym 12 nowych). Chyba kiedyś miałem podobny problem w innym modelu i dlatego zostały zakupione emaxy ;-)

  14. Przez świetne artykuły zastanawiam się nad powrotem do modelarstwa. Już kombinuje jak przerobić moją starą SANWE na 2.4GHz i uruchomić coś latającego.

  15. jak sprawdzić czy popsułem lrs tx? nie swiecą się diody i nie mam możliwości wyboru portu com

    • A co z nim zrobiłeś że nie działa? Ja też ubiłem ze dwa razy któryś z modułów (chyba RX) podczas zabaw, i musiałem podlutować programator ISP żeby wrzucić na nowo soft bo moduł był kompletnie martwy. Możliwą przyczyną było odłączenie zasilania podczas pracy UARTa, tu wychodzi brak rezystorów na liniach, ale równie dobrze mogło się to stać od grzebania lutownicą na płytce.

    • prawdopodobnie odłączyła mi się antena z gniazda na płytce, bo z powodu krótkiego kable usb całość wisiała w powietrzu :)

  16. Witam :)
    Bardzo ciekawy poradnik – gratki
    Mam jedno pytanie techniczne :) W związku z tym, że kiedyś udało mi się kupić moduły OrangeRX Open LRS 433MHz Transmitter 100mW ( JR/Turnigy Compatible), i mam “potrzebę” przeprogramowania jednego z nich na RX, to prosił bym o potwierdzenie, czy dobrze “kombinuję” Potrzebuję TYLKO sPPM, więc wyjście tego sygnału mogę “pobrać” z tego miejsca:

Leave a Reply

Your email address will not be published. Required fields are marked *

Please leave these two fields as-is: